http 500内部服务器错误的解决办法(windows xp + IIS5.0)

admin3个月前 (07-02)网络知识144

    本次解决问题的环境是windows xp + iis5.0,权限设置正常,打开asp文件即会提示&http 500内部服务器错误&,目前问题已经解决,归纳解决方案如下,希望能给大家带来帮助。(如果真的帮了你的忙了,别忘了回复一下,谢谢!)

ScreenShot_2026-07-02_070646_308.jpg

    1、在控制面板—管理工具—服务 中确认&Distributed Transaction Coordinator&服务有没有启动,没有启动就启动它,并设置成自动。
如果遇到&Distributed Transaction Coordinator&服务无法启动怎么办?
在命令提示符里输入
msdtc -resetlog
然后就可以启动该服务了。

2、运行 c:InetpubAdminScripts 脚本文件夹中的 synciwam.vbs文件
3.在命令行状态下输入以下命令(注意大小写):
cd c:windowssystem32inetsrv
rundll32 wamreg.dll, CreateIISPackage
regsvr32 asptxn.dll

然后重新启动IIS服务,asp文件就可以正常访问了